Avon - Login - Help

Browser

For your security, we require a minimum browser level of Microsoft® Internet Explorer v5.5 and above, Firefox 2.0, or Netscape Navigator®/Netscape® Communicator v6.0 and above.

Special Instructions for AOL Users:

Access via America Online® (AOL) requires the latest AOL software (version 4.0 or higher).

To find out what version you're using, select About AOL from the Help menu on the AOL site.

Note: In order for this site to work, you must also download and use one of the recommended browsers, rather than the browser that comes with AOL. The AOL browser doesn't support all of the features that this site requires.

To download Microsoft® Internet Explorer, enter http://www.microsoft.com/ie on your AOL browser, and follow the instructions.

To download Firefox®, enter http://firefox.org.nz/ on your AOL browser, and follow the instructions.

To download Netscape Navigator®, enter the keyword Netscape on the AOL site and follow the instructions.